AE101 Owners Club
Please log in or register


AE101 Owners Club is a group of 7th gen Corolla enthusiasts from all over the world. If you're a fellow enthusiast, then join us today!
 
HomeCalendarUsergroupsRegisterLog in
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Latest topics
» 4AFE Breather Hose blocked off
Fri Jul 14, 2017 12:21 pm by TheTree

» removing A240L AUTO TRANS FROM AE92
Mon Jul 10, 2017 10:06 am by Shaun Morgan

» Grandpa`s Corolla
Sat Jul 08, 2017 5:25 pm by Stian Leikvoll

» Lexus IS300
Sat Jul 08, 2017 1:10 pm by gold94corolla

» An old member returns
Sat Jul 08, 2017 1:45 am by Yankee

» wind deflectors
Fri Jul 07, 2017 10:20 pm by emmet.harten3

» Mines plug & play ECU 4A-GE 20V Silvertop
Tue Jul 04, 2017 7:54 pm by Chfoxch

» How much will cost to built my corolla ae101 like the fx gt 93
Sat Jul 01, 2017 10:46 am by AntonioRolla

» E10 corolla saloon Rear Window Visor
Sat Jul 01, 2017 6:58 am by emmet.harten3

» Let us know who you are! (name, photo, etc)
Thu Jun 29, 2017 10:47 am by Nilesh Lala

» air intake and hks muffler with down piping
Wed Jun 28, 2017 10:24 pm by Yankee

» New from Los Angeles, CA, USA
Wed Jun 28, 2017 10:19 pm by Yankee

» Win 2 tickets to Knockhill - 2nd July
Wed Jun 28, 2017 7:21 pm by oilman

» 1994 AE101 Maroon/ Black wagon
Wed Jun 28, 2017 11:47 am by Nilesh Lala

» AE101 arm rest
Sun Jun 25, 2017 9:22 pm by emmet.harten3

Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 91 on Fri Apr 10, 2015 3:08 pm
Top posters
miib14 (7347)
 
gold94corolla (5269)
 
SHEHROZE ARAIN (1802)
 
MirrorEyes (1556)
 
magweal (1410)
 
Sgt_Lyna (1247)
 
Kiwi-Corolla (1218)
 
Corolla Sound (1106)
 
knite (1105)
 
Argew24 (1039)
 
Statistics
We have 3594 registered users
The newest registered user is KenP1169

Our users have posted a total of 42321 messages in 2919 subjects
Search
 
 

Display results as :
 
Rechercher Advanced Search
Please Donate to the Site
Like Us On Facebook!

Share | 
 

 4AFE AC1 and ACT wiring help

View previous topic View next topic Go down 
AuthorMessage
redwing0001
New Member
New Member


Posts : 37
Reputation : 3
Join date : 2014-10-26

PostSubject: 4AFE AC1 and ACT wiring help   Mon Feb 09, 2015 11:33 pm

anyone with experience wiring a 4afe harness, assistance needed.

I am at the tail end of the project..... car is running beautifully.... the only problem is that I have no idea how AC1 should be connected....

normally AC1 pin from the ecu should be connected to the AC1 on the a/c amplifier... but since my car originally came with carbs, no AC1 and no ACT pins there.

what I did was to connect AC1 pin to the compressor 12V wire..... although I am not sure if it was supposed to be connected to "ground" when the aircon is off....

I also tried connecting a relay between AC1 and the compressor 12V wire and all this does is to make my engine idle at 1200 rpm.... in this configuration, AC1 pin is unconnected to anything...

so my question is, should the AC1 pin be connected to ground as what I have currently OR should it be "unconnected" when aircon is off?

if the AC1 pin should be unconnected when a/c is off, does this mean something is faulty with my ecu and something is causing the normal idle speed to be 1200 rpm at normal temps?

I know that other people leave AC1 pin unconnected and it does not change the idle speed, but mine does..... is my ecu at fault for this?

If I have to get another ecu.... I might as well invest in a 4age blacktop 5speed or heck,6 speed ecu as replacement.... almost the same pinouts and quite easy to rewire the 4afe harness to fit the BT ecu..... I just need to make myself an adaptor....

but currently, I do not have any other ecu to test, that's why I asked here. I wanted to ask the local enthusiasts here, but questions like there are way over their heads already.... the only people who know harness rewiring here in the philippines do not know how to troubleshoot problems with EFI rewiring OR, will not tell me unless they repair the harness themselves.

Thanks!
Back to top Go down
redwing0001
New Member
New Member


Posts : 37
Reputation : 3
Join date : 2014-10-26

PostSubject: Re: 4AFE AC1 and ACT wiring help   Sat Mar 07, 2015 6:59 pm

I just test with another ecu and it does the same thing..... when unconnected the idle is high.... meaning it has to be grounded of sorts for idle to be normal.

UPDATE:

I just replaced the ecu..... there was a problem that I encountered with this ecu I ran...... cyl 1 and 3 Spark plugs were dry black soot while 2 and 4 are nice brown... meaning something is not correct in the ecu.... I decided to replace it.... and I got myself 2 5AFE ecus for my use.... 1 is a 1993 to 1995 5AFE ecu (89661-1A120) and the other one a 5AFE A/T (89661-1A130) both are 2nd gen and have the same pinouts..... I will just make an ecu adaptor for the A/T ecu

Plus I found a nice early 3rd gen 7AFE ecu (89661-1A280) that I can play around with.... this one may run using the 4AFE distributor, I just need to make myself a ecu adaptor so I can use this 26-16-22 ecu on my 2nd gen harness (25-16-12)...

I can verify that this is not a lean burn model..... it has the same G2 G- NE+ NE- IGF IGT pins found on 4AFE 2nd gen ecu and yet, it has 4 injector outputs... nor is it a model that has a separate NE pin for the crank angle sensor found in the oil pump since it has NE and NE- pins.
Back to top Go down
redwing0001
New Member
New Member


Posts : 37
Reputation : 3
Join date : 2014-10-26

PostSubject: Re: 4AFE AC1 and ACT wiring help   Wed May 13, 2015 3:04 am

UPDATE to this update:

I decided to replace the 5AFE ecu with a 3SFE one.... now it works even better than even the 4AFE one.....

This is the ecu part number that I got: 89661-2D140... An A/T Caldina.

The only other change I did was to change the NSW pin. Originally, I tied this wire to the starter line so it has 12V only when you start using a manual ecu.... Its different for an A/T ecu... This has the effect of telling an A/T ecu that you are in gear and will give a higher idle speed than 750rpm, and maybe worse fuel mileage than before..... I then rewired the NSW pin and connected it to the Ignition ON wire on the ignition switch. Whenever you have the key in ON, it powers the NSW pin automatically.

This tells the ecu that the engine is in neutral and will lower the idle speed back to 750 rpm, and hopefully, better fuel mileage.

it now ides at 750 rpm, compensates for any load AND seems to have better fuel mileage than any other ecu I used so far.

But the best thing about this is the performance of having a 7AFE injector on my 5A block is realized with this ecu.... its just way better than any 7AFE or 4AFE or even the 5AFE ecu I used before.

I had to make an ecu adaptor to make it work since it is an automatic ecu (26-16-22) and my harness is for a manual (26-16-12).

The pins names are the same, its just the pin locations are different.

Also I used a 7AFE fuel injector (192 or 200cc/min) .... its a bit smaller than the 3SFE injector (213 cc/min) so the ecu can  maximize the injector I am using now but they are close enough that the ecu may compensate for it.

When looking for a compatible ecu for your 4AFE engine, make sure that the ecu you want to use have the following pin names:

RSO, RSC - ISCV valve control
G1,G- cam sensor, I think.....
NE+, NE- crank sensor?

IGF, IGT power and tacho wires

VISC a/c idle up control

If the pin names include G1, G2, G, G-, NE, its for a different distributor, the one you want to use for your 4A would be the 4AGE silvertop/blacktop one. And ecus with this kind of dizzy would also have 4 injector wires for a sequential injection instead of batch fire like the 2nd gen 4AFE.

There may be 4AFE/7AFE ecus that may include G2, G- pin names instead of G1,G- pins. I have tested this (89661-1A280) and it does not work on my 4AFE distributor.

And then there are 7AFE ecus that have a totally different pins name and they may not include any NE or G pins at all.... These are the distributorless ecus and are to be used on the 7AFE lean burn engines.

Apparently these lean burn 7AFE have a different cylinder head design than non lean burn.... The most obvious one is that these engines have the injectors in the head and not on the intake manifold.

Now I still connect AC1 directly to the compressor coil to get lower idle.... can't be helped.... I think this is needed for proper operation.

What I now plan to do to the ACT pin is to connect it to the coil of a 12V SPDT relay (single pole, double throw) and connect the other end to the a/c amp power wire then connect the relay contacts to the a/c amp main power wire as well so that the ecu itself controls the a/c amp when accelerating hard.

When extra power is needed, the ecu will power the ACT pin (I hope), disconnecting the wires that power the a/c amp AND turns off the compressor automatically....

Each time you need extra acceleration, the ecu does this for extra power.
Back to top Go down
Sponsored content




PostSubject: Re: 4AFE AC1 and ACT wiring help   

Back to top Go down
 
4AFE AC1 and ACT wiring help
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
AE101 Owners Club :: AE101 Tech: DIYs, Q&A :: Engine & Fuelling-
Jump to: